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Purpose: Installing the Hollywood theme is as easy as installing every other simple WordPress theme. This
manual will help you to install the theme and point out the specifics. Do not worry, the Hollywood theme is
not a complicated theme framework nor does it have a lot of theme options that can confuse you. It will be
a breeze!

Please notice, that it is out of the scope of this video to explain you WordPress basics. For all general

WordPress questions, please consult the official documentation: https://codex.wordpress.org/Main_Page
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Hollywood [heme Manual

Installation

Installing Hollywood WordPress Theme is as easy as it gets, but make sure to read this manual till the end. It will save

you a lot of time.

If you want to install the content from the Hollywood Theme Demo, please check the how-to-install-demo-content.txt

and upload the hollywood-theme-demo-content.xml as explained.

Let’s get started:

1.

Upload & Activate
Upload the hollywood.zip or hollywoodbynight.zip file via the theme upload function Themes » Install Themes
» Upload in your WordPress Administration (wp-admin) and activate the Theme.

Front Page & Blog Setup
Create a page named Home and a page named Blog. Apply the Front Page page template to the Home page
(Attributes section on the right when editing the page).

Then go to Appearance » RichWP Options » Static Front Page, choose “A static page” under “Front page
displays. Set your Home page for Front and your Blog page for Posts page.

Now you can set up the content of your Front Page and we actually found a pretty simple and WordPress original
way of doing so without any Page Builders or other clumsy scripts that just get in the way. All you have to do is to
create simple menus. Perfect, right? Everything about the Front page setup is being explained in the next section of
this manual.

Menu Setup
Now, let’s set up your Primary-, Select- as well as Icon- and Footer Menus under Appearance » Menu in your
WordPress Administration. The Featured Section as well as the Categories and Tags Lists on the Home Page are

also being created and edited via a menu as well.

Primary Menu

The menu setup works in the same way than with the the WordPress Standard Themes. In general you just have to
choose your pages, posts, categories, tags, WooCommerce endpoints or custom links on the left and add them to

the Primary Menu.

Make sure that you select Primary Menu as the location for this menu:
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Menu Settings

Auto add pages | Automatically add new top-level pages to this menu

Theme locations Primary Menu
Icon Menu (Currently set to: lconmenu)

Footer Navigation (Currently set to: Short)

As you can see in the theme demo, the Primary Menu does allow you to set up a multi-level drop down structure. To

do this, simply drag and drop your menu items you into the right position and stack accordingly. Ex.:

Sample Page sub item Page v

Sample Page sub item Page v

Single Featured Video Section

FEATURED VIDEO

BILLABONG SPRING 2015 // A BIKINI KINDA LIFE: MOOREA, TAHITI

300 x 250
Banner

OPTIONAL WIDGET AREA

Menu Name

Featured Video
Iget area becomes available when you have set

M Struct ured front page video post. if you choose not to
enu structure , then the featured video will stretch the whole
Drag each item into the order you prefer. Click the arrow on the right of the item to reveal additional configu the container. In this prime location you could

advertising, a newsletter sign up form or basi-

AP O cally every widget you want.
Video Source: A Bikini Kinda Life by 8i
A BIKINI KINDA LIFE | AUGUST 26,2015 Menu Settings
Auto add pages Automatically add new top-level pages to this menu
Theme locations Primary Menu (Currently set to: Primary)
Page 3 Of 1 2 : Icon Menu (Currently set to: Icon Menu)

Footer Navigation (Currently set to: Footer)
Front Page Featured Single Video
Front Page Featured List

Front Page Cat & Tags Post List (Currently set to: Front Page Cat & Tags Post List)



The setup of the Featured Posts Section works in the same way than the other menus in the theme. In general
you just have to create a menu, choose a posts and add it to the Front Page Featured Single Video location and
you are done. Pages can be added as well. The Advertising Section next to it is a widget area which can be editied

under Appearance » Widgets.

Front Page Featured List

NEW & NOTEWORTHY >

KATE ON SCHWINN BOY GIRL DIPS A BIKINI KINDA LIFE: BEHIND TWENTY FOUR SEVEN - BIKINI ABIKINI KINDA LIFE
PTEMBER 26, 2015 SEPTEMBER 5, 2015 THE SCENES COLLECTION AUGUST 26,2015
AUGUST 30, 2015 AUGUST 27,2015
720 v N NI INANAY D ANINIED
Menu Name  New & Noteworthy
Menu Structure
Drag each item into the order you prefer. Click the arrow on the right of tF
Kate on Schwinn Post Vv
Boy Girl Dips Post Vv
Emily Post Vv
A Bikini Kinda Life: Behind The Post Vv
Scenes
Twenty Four Seven - Bikini Post Vv
Collection
A Bikini Kinda Life Post Vv
Menu Settings
Auto add pages Automatically add new top-level pages to tl
Theme locations Primary Menu (Currently set to: Primary)
Page 4 Of 1 2 Icon Menu (Currently set to: Icon Menu)

Footer Navigation (Currently set to: Footer)

Front Page Featured Single Video (Currently :
Front Page Featured List

Front Page Cat & Tags Post List (Currently set



It works the same way than the Single Featured Video Setup. Create a Menu, add six posts and apply it to the Front

Page Featured List location. If you do not set this menu up, then the 6 latest posts will be shown instead. The menu

title will be displayed as the headline.

Front Page Cat & Tags Post List

FITNESS

SURFING

ABIKINI KINDA LIFE: BEHIND

‘THE SCENES

MODELS

KATE ON SCHWINN

BEACH

ABIKINI KINDA LIFE: BEHIND

THE SCENES
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SARFDEGNA POLEDANCE
FITNESS WITH NICOLE

SURF TRIP: MALDIVES
JULY 12,20

UNDERWATER WALKING IN A
KALOEA BIKINI
AUGUST 19,2015

i
KITTY HAWK SURFING

JULY 26,20



Menu Name  Front Page Cat & Tags Post List

Menu Structure

Drag each item into the order you prefer. Click the arrow on the right of the i

Fitness Category ¥
Surfing Category ¥
Models Category ¥
Beach Tag v
Fitness Motivation Tag v

Menu Settings

Auto add pages Automatically add new top-level pages to this
Theme locations Primary Menu (Currently set to: Primary)
Icon Menu (Currently set to: lcon Menu)
Same here, but this time we Footer Navigation (Currently set to: Footer) create a menu, add categories or

Front Page Featured Single Video (Currently set
Front Page Featured List
Front Page Cat & Tags Post List

tags to it and apply it to the Front Page Cat & Tags list menu

location.

There you have it, a page layout set up in the WordPress way. Just how it should be!

Icon Menu

Create a new menu and select the lcon Menu location. To set up icons to your social networks like twitter,
Facebook & co. simply copy and paste your URLs to custom link items and add them to the menu. The icons will

automatically appear in your icon menu.

Custom Links

URL /facebook.com/richwp

Link Text | facebook

Add to Menu

IMPORTANT: To speed up your site, the icons should be set up with their css-classes. This way we tell the theme

directly which icon to use and it does not have to read out your target URLs and set the required CSS classes itself

(see below).

The following social icons are available (the list also shows the icons CSS classes):
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G+: icon-gplus

Twitter: icon-twitter
Facebook: icon-facebook
Pinterest: icon-pinterest
Youtube: icon-youtube
Vimeo: icon-vimeo

Tumblr: icon-tumblr

Flikr: icon-flikr

Linked In: icon-linked-in
Soundcloud: icon-soundcloud

XING: icon-xing

Setting up Icons via CSS classes:

Besides the mentioned social icons above, the theme also includes additional icons that might come in handy. To

set up these additional icons and/or make your social icons faster, make sure that your menu CSS classes are
enabled. If not, click on “Screen Options” in the top right corner while being on Appearance >> Menu and tick the
little box next to CSS Classes.

Show advanced menu properties

Link Target CSS Classes Link Relationship (XFN) Description

Screen Options

You can apply the following classes to menu items in the Icon Menu:

Shopping Cart: icon-basket
Account: icon-user
Envelope: icon-email

RSS: icon-rss

Example: To create the Shopping Cart icon in the demo | have set up menu element to my WooCommerce

Shopping Cart in the menu editor. | have then added the icon-basket CSS class.

Shopping Cart Page

Navigation Label Title Attribute
‘ Shopping tar‘c

CSS Classes (optional)

icon-basket

Move Up one Down one Under facebook To the top
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Original: Cart

Remove | Cancel



Feel free to add different icons as the ones listed above via a new icon font. If you need help, feel free to write in and

we can add the needed icons for you for a little service charge. Any programmer familiar with CSS should be able to

help you as well. The icons used are from http://fontello.com/

Select Menu

You can create a select menu for your woo commerce shop. This one is really useful if you have a lot of products in
a lot of locations. Create a new menu and select one of the Select Menu Shop location. This Select Menus will

display a flat list of your menu items. The menu title will be displayed as the select menu label.

Footer Menu

Create a new menu and select the Footer Navigation location. The Footer Menu will display a flat list of your menu

items.

4. Widgets
The theme comes with several Widget Areas. Set up your widgets under Appearance » Widgets in your
WordPress Admin. If you need additional widgets, try a plugin search under Plugins » Add New. There you find
rotating banner and other advertising related widgets as well as email sign up forms from your favourite email

responder service and much more.

For testing, feel free to copy and paste this code into a text widget of one of the widget areas to display a 728 x
90px banner:

<a href="#"><img height="auto" alt="Ad Code" src="//demo.richwp.com/videoworld/
files/2015/11/728x90dummzbanner.png"” scale="0"></a>

5. Title & Logo
Set up your Logo or Page Title under Appearance » Customize » Title & Logo. | recommend using a
resized .png or an .svg file with a transparent background if you want to set up an image logo.

We recently became fans of SVG logos. SVG stands for scalable vector graphics and allows you to have an

absolutely crisp and sharp looking logo (see http://richwp.com) without any unwanted pixelation effect. You can
export .svg files with Google Drawings (in your Google Drive) or with any better vector graphic program. .svg fies will
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not be displayed in IE8 or older.

Always test what logo size fits best for your design. Also test on smart phones and tablets.

6. Colours
To change the lead colors, go to Appearance » Customize » Colors in your WordPress admin. There you can
change your header as well as lead colors.

7. Enjoy Your New Site!

Page Templates

The Theme comes with a variety of page templates that you can apply to your pages (not posts). The Full-Width Page
Template uses the whole content container width for the content. No Sidebar will be displayed. The Full-Width without
Title Page Template does the same, but it doesn’t displays a title. The purpose of these page templates is to give you an
alternative layout option should you want to set up a static front page. There is also the Subpage List Page Template.
Once applied, to a parent page, all of the page’s child pages will be listed under the content box.

Media Settings

The Theme natively creates all the image sizes needed for your site. However, you might want to create thumbnails for
your galleries or different sizes for your product images of your shop. You can set them up under Settings » Media in
your WordPress Admin.

If you want to install the theme on an already established site, where you uploaded images before you activated the
Hollywood Theme, you should run a plugin to create the image sizes needed for the theme. We recommend the free
“Regenerate Thumbnails” plugin: https://wordpress.org/plugins/regenerate-thumbnails/

Featured Images and Automatic Video Thumbnails

In general, add featured images to all your posts! The theme takes care of scaling the featured images to the appropriate
sizes. Should you use this theme on already existing site, you can regenerate the the needed image sizes with a plugin
like this: hitp: ' i

to automatically create video thumbnails you can use a video thumbnail plug like this http://wordpress.org/extend/
plugins/video-thumbnails/, but there are plenty of others available as well.

Contact Forms, Social Sharing Buttons & Galleries

In the RichWP Theme Demos as well as on most of our personal sites we use the functionality of the WordPress Jetpack
plugin to build our contact forms or to add social sharing buttons and galleries, but feel free to use your own plugins of
choice. For galleries and video player plugins, make sure that they work well in a responsive environment.
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Responsivene & Adaptive

This theme is responsive and scales from smart phones all the way up to big desktop screens. To adapt the readability of
the main content to the user’s device, some elements will be disabled or formatted in a different way on the smaller
resolution screens.

WooCommerce

This theme is WooCommerce compatible. Feel free to install and setup WooCommerce and start selling your products,
services or subscriptions.

Translating the Hollywood Theme

The RichWP Hollywood Theme theme comes with a .pot language file. This is needed to translate the theme. For for
information, visit http://codex.wordpress.org/Translating_WordPress There you will find a list of tools and a general
explanations about how to make translation. It has been written for WordPress itself, but the principles and techniques
are the same. | personally prefer to translate with a plugin called Loco Translate: https://wordpress.org/plugins/loco-
translate/

A German Translation file is included.

Credits and License Information
jQuery Scripts

## jQuery Equal Height

Author: Micah Godbolt
License: MIT (http: nsource.org/licen mit-license.php)
Homepage: http://codepen.io/micahgodbolt/pen/Fgal ¢

## Sticky-kit v1.0.4

Author: Leaf Corcoran
License: WTFPL (http://sam.zoy.org/wtfpl/)
Homepage: http://leafo.net

## hoverintent r7

Author: Brian Cherne
License: MIT (http://opensource.org/licenses/mit-license.php)

Homepage: http://cherne.net/brian/resources/jquery.hoverintent.html

## jQuery Superfish Menu Plugin
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Author: Joel Birch
License: MIT (http://opensource.org/licenses/mit-license.php) & GPL (http://www.gnu.org/licen L.html)
Homepage: http://cherne.net/brian/resources/jquery.hoverintent.html

#i# tinynav v1.2

Author: viliamis
License: MIT (http://opensource.org/licenses/mit-license.php)

Homepage: http://tinynav.viljamis.com

## Selecter v3.1.2

Author: Ben Plum
License: MIT (http://opensource.org/licenses/mit-license.php)

Homepage: http://formstone.it/selecter/

#4# FitVids 1.1

Author: Chris Coyier + Dave Rupert

License: WTFPL (http://sam.zoy.org/wifpl/)
Homepage: http://css-tricks.com http://daverupert.com http://www.alistapart.com/articles/creating-intrinsic-ratios-for-

video/

Font license info
## Zocial
Copyright (C) 2012 by Sam Collins

Author: Sam Collins
License: MIT (http://opensource.org/licenses/mit-license.php)

Homepage: http://zocial.smclins.com/

## Typicons

Copyright (C) 2012 by Stephen Hutchings

Author: Stephen Hutchings
License: SIL (http://scripts.sil.org/OFL)

Homepage: http://typicons.com/
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## Iconic
Copyright (C) 2012 by P.J. Onori

Author: P.J. Onori
License: SIL (http://scripts.sil.org/OFL)

Homepage: http://somerandomdude.com/work/iconic/

## Entypo
Copyright (C) 2012 by Daniel Bruce

Author:  Daniel Bruce
License: SIL (http://scripts.sil.org/QFL)
Homepage: http://www.entypo.com

Other:

## WordPress specific CSS (formatting, widgets, etc.) & theme architecture loosely based on the Twenty Fifteen
Standard Theme

Author: The WordPress Team
License: GNU General Public License v2 or later (http://www.gnu.org/licenses/gpl-2.0.html)
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