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Purpose: Installing the Products, Arts & Services Theme is as easy as installing every other simple
WordPress theme. This manual will help you to install the theme and point out the specifics. Do not worry,
the Products, Arts & Services Theme is not a complicated theme framework nor does it have a lot of
theme options that can confuse you. It will be a breeze!

Please notice, that it is out of the scope of this video to explain you WordPress basics. For all general

WordPress questions, please consult the official documentation: https://codex.wordpress.org/Main_Page
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Products, Arts & Services
Theme Manual

Installation

Installing the Products, Arts & Services Theme is as easy as it gets, but make sure to read this manual till the end. It

will save you a lot of time.

If you want to install the content from the Products, Arts & Services Theme Demo, please check the how-to-install-

demo-content.txt and upload the products-arts-services-content.xml as explained.

Let’s get started:

1.

Upload & Activate
Upload the products-arts-services.zip or products-arts-services-dark.zip file via the theme upload function
Themes » Install Themes » Upload in your WordPress Administration (wp-admin) and activate the Theme.

Front Page & Blog Setup
Create a page named Home and a page named Blog. Apply the Front Page page template to the Home page
(Attributes section on the right when editing the page).

Then go to Appearance » RichWP Options » Static Front Page, choose “A static page” under “Front page
displays. Set your Home page for Front and your Blog page for Posts page.

Now you can set up the content of your Front Page and we actually found a pretty simple and WordPress original
way of doing so without any Page Builders or other clumsy scripts that just get in the way. All you have to do is to
stack pages and posts (if you like) upon each other in a dedicated Menu (Menu Location: Front Page Posts & Pages
List). Simple right?

Let’'s say you would like to add a slider to your Front Page. Simple create a new page, insert the slider of your
choice. Save this page and go to Appearance » Menu create a new menu, apply it to the Front Page Posts &
Pages List menu location and add your slider page to this menu.

Let’s say you would like to add some products from your WooCommerce store directly to your front page. Just
create a new page, add the appropriate product shortcode to this page, save and add this page to your Front
Page Posts & Pages List menu. You find all WooCommerce product shortcakes here: https://
docs.woothemes.com/document/woocommerce-shortcodes/

To give you more flexibility we have added some useful page templates, that behave differently on the front page.
Apply them as needed:
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Full Width - No Title: No title will be shown
On Front Page Image Left & Content Right: On the front page, the featured image will be on the left and the
content on the right. When you click on the “Continue reading” button, the page will be displayed like a normal page.

SAMPLE PAGE

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Ae-
nean commodo ligula eget dolor. Aenean massa. Cum sociis
natoque penatibus et magnis dis parturient montes, nasce-
tur ridiculus mus. Donec quam felis, ultricies nec, pellen-

tesque eu, pretium...

Continue reading

MYN

On Front Page Image Right & Content Left: On the front page, the featured image will be on the right and the
content on the left. When you click on the “Continue reading” button, the page will be displayed like a normal page.

ANOTHER TEST PAGE

Need help? Use the Help tab in the upper right of your
screen. Need help? Use the Help tab in the upper right of
your screen. Need help? Use the Help tab in the upper...

Continue reading

Subpage List: This page template lists its sub pages underneath its title and the content.

If you want to change the order of the stacked front page content, simply drag & drop the menu elements to their
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desired location.

Here is a screenshot of the Front Page menu setup of the theme’s demo:

Menu Name  Front Page Stack

Menu Structure

Drag each item into the order you prefer. Click the arrow on the right of the item to re

Slider for Front Page Page ¥
Be Everything, Sell Everything Page ¥
Easily Add Content to the Front Page ¥
Page

Simply by adding Pages to a Page v
Menu

In The Menu Editor Page ¥
Elegant and 100% WordPress Page ¥
Full WooCommerce Integration Page ¥
Front Page Gallery Page ¥
Contact Page ¥

Menu Settings
Auto add pages Automatically add new top-level pages to this menu

Theme locations Primary Menu (Currently set to: Primary)
Icon Menu (Currently set to: Icon Menu)
Footer Navigation (Currently set to: Footer)
Select Menu Shop (Currently set to: Shop Select)
Front Page Posts & Pages List

One Page Setup
Every page or post that you have added to your front page contains a so called anchor link. Anchor links are links
within a page and we need them to create our One-Page navigation.
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The anchor link is simply the page or post slug, sample-page in this case:

Edit Page AddNew

Sample Page

Permalink: http://127.0.0.1:8080/wordpress/| sample-page P OK |

You can now create a Custom Link to this anchor in the menu editor. User the complete permalink as the URL and
add a # before the slug. The link should look like this http://yourdomain.com/#sample-page

By using the full permalink starting with the http:// you can feel free to combine your front page anchor links with
links that are not on the front page, your blog for example.

In the demo | use the Front Page template with a slider. This slider has been created using the Soliloquy Slider
Plugin. A free version with less features is available here. | cropped the images in a graphic software to 1165px x
600px. The galleries are set up using the Jetpack gallery plugin. You can find these plugins by doing a search in your
WordPress plugin section.

3. Menu Setup
Now, let’s set up your Primary-, Select- as well as Icon- and Footer Menus under Appearance » Menu in your

WordPress Administration.

Primary Menu

The menu setup works in the same way than with the the WordPress Standard Themes. In general you just have to
choose your pages, posts, categories, tags, WooCommerce endpoints or custom links on the left and add them to

the Primary Menu.

Make sure that you select Primary Menu as the location for this menu:

Menu Settings

Auto add pages Automatically add new top-level pages to this menu
Theme locations Primary Menu

Icon Menu (Currently set to: Iconmenu)

Footer Navigation (Currently set to: Short)
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As you can see in the theme demo, the Primary Menu does allow you to set up a multi-level drop down structure. To

do this, simply drag and drop your menu items you into the right position and stack accordingly. Ex.:

Sample Page sub item Page

Sample Page sub item Page

Icon Menu

Create a new menu and select the lcon Menu location. To set up icons to your social networks like twitter,
Facebook & co. simply copy and paste your URLs to custom link items and add them to the menu. The icons will

automatically appear in your icon menu.

Custom Links

URL /facebook.com/richwp

Link Text fa Cebook|

Add to Menu

IMPORTANT: To speed up your site, the icons should be set up with their css-classes. This way we tell the theme

directly which icon to use and it does not have to read out your target URLs and set the required CSS classes itself

(see below).

The following social icons are available (the list also shows the icons CSS classes):

G+: icon-gplus
Twitter: icon-twitter
Facebook: icon-facebook

Pinterest: icon-pinterest

Page 6 of 12



Youtube: icon-youtube
Vimeo: icon-vimeo

Tumblr: icon-tumblr

Flikr: icon-flikr

Linked In: icon-linked-in
Soundcloud: icon-soundcloud

XING: icon-xing

Setting up Icons via CSS classes:

Besides the mentioned social icons above, the theme also includes additional icons that might come in handy. To
set up these additional icons and/or make your social icons faster, make sure that your menu CSS classes are
enabled. If not, click on “Screen Options” in the top right corner while being on Appearance >> Menu and tick the

little box next to CSS Classes.

Show advanced menu properties

Link Target CSS Classes Link Relationship (XFN) Description

Screen Options

You can apply the following classes to menu items in the Icon Menu:

Shopping Cart: icon-basket
Account: icon-user
Envelope: icon-email

RSS: icon-rss

Example: To create the Shopping Cart icon in the demo | have set up menu element to my WooCommerce

Shopping Cart in the menu editor. | have then added the icon-basket CSS class.

Shopping Cart Page

Navigation Label Title Attribute
‘ Shopping tart

CSS Classes (optional)

icon-basket

Move Up one Down one Under facebook To the top
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Feel free to add different icons as the ones listed above via a new icon font. If you need help, feel free to write in and

we can add the needed icons for you for a little service charge. Any programmer familiar with CSS should be able to

help you as well. The icons used are from http://fontello.com/

Footer Menu

Create a new menu and select the Footer Navigation location. The Footer Menu will display a flat list of your menu

items.

4. Widgets
The theme comes with several Widget Areas. Set up your widgets under Appearance » Widgets in your
WordPress Admin. If you need additional widgets, try a plugin search under Plugins » Add New. There you find
rotating banner and other advertising related widgets as well as email sign up forms from your favourite email
responder service and much more.

For testing, feel free to copy and paste this code into a text widget of one of the widget areas to display a 728 x
90px banner:

<a href="#"><img height="auto" alt="Ad Code" src="//demo.richwp.com/videoworld/

files/2015/11/728x90dummzbanner.png" scale="0"></a>

Please note, that the Featured Posts Widget Area will only be shown if you have set up your Featured Posts section

(see above).

5. Title & Logo
Set up your Logo or Page Title under Appearance » Customize » Site Identity. | recommend using a

resized .png or an .svg file with a transparent background if you want to set up an image logo.

We recently became fans of SVG logos. SVG stands for scalable vector graphics and allows you to have an
absolutely crisp and sharp looking logo (see http://richwp.com) without any unwanted pixelation effect. You can
export .svg files with Google Drawings (in your Google Drive) or with any better vector graphic program. .svg fies will

not be displayed in IE8 or older.

Always test what logo size fits best for your design. Also test on smart phones and tablets.
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6. Colours
To change the lead colors, go to Appearance » Customize » Colors in your WordPress admin. There you can
change your header as well as lead colors.

7. Enjoy Your New Site!

Page Templates

The Theme comes with a variety of page templates that you can apply to your pages (not posts). The Full-Width Page
Template uses the whole content container width for the content. No Sidebar will be displayed. The Full-Width without
Title Page Template does the same, but it doesn’t displays a title. The purpose of these page templates is to give you an
alternative layout option should you want to set up a static front page. There is also the Subpage List Page Template.
Once applied, to a parent page, all of the page’s child pages will be listed under the content box.

Media Settings

The Theme natively creates all the image sizes needed for your site. However, you might want to create thumbnails for
your galleries or different sizes for your product images of your shop. You can set them up under Settings » Media in
your WordPress Admin.

If you want to install the theme on an already established site, where you uploaded images before you activated the
Products, Arts & Services Theme, you should run a plugin to create the image sizes needed for the theme. We

recommend the free “Regenerate Thumbnails” plugin: hitps://wordpress.org/plugins/regenerate-thumbnails/

Featured Images and Automatic Video Thumbnails

In general, add featured images to all your posts! The theme takes care of scaling the featured images to the appropriate
sizes. Should you use this theme on already existing site, you can regenerate the the needed image sizes with a plugin
like this: http://wordpress.org/extend/plugins/regenerate-thumbnail

to automatically create video thumbnails you can use a video thumbnail plug like this http://wordpress.org/extend/

plugins/video-thumbnails/, but there are plenty of others available as well.

Contact Forms, Social Sharing Buttons & Galleries

In the RichWP Theme Demos as well as on most of our personal sites we use the functionality of the WordPress Jetpack
plugin to build our contact forms or to add social sharing buttons and galleries, but feel free to use your own plugins of
choice. For galleries and video player plugins, make sure that they work well in a responsive environment.
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Responsivene & Adaptive

This theme is responsive and scales from smart phones all the way up to big desktop screens. To adapt the readability of
the main content to the user’s device, some elements will be disabled or formatted in a different way on the smaller
resolution screens.

WooCommerce

This theme is WooCommerce compatible. Feel free to install and setup WooCommerce and start selling your products,
services or subscriptions.

Translating the Products, Arts & Services Theme

The RichWP Products, Arts & Services Theme theme comes with a .pot language file. This is needed to translate the
theme. For for information, visit http://codex.wordpress.org/Translating_WordPress There you will find a list of tools and a

general explanations about how to make translation. It has been written for WordPress itself, but the principles and
techniques are the same. | personally prefer to translate with a plugin called Loco Translate: https://wordpress.org/

plugins/loco-translate/

A German Translation file is included.

Credits and License Information
jQuery Scripts

## jQuery Equal Height

Author: Micah Godbolt
License: MIT (http: nsource.org/licen mit-license.php)
Homepage: http://codepen.io/micahgodbolt/pen/Fgal ¢

## hoverintent r7

Author: Brian Cherne
License: MIT (http://opensource.org/licenses/mit-license.php)

Homepage: http://cherne.net/brian/resources/jquery.hoverintent.html

## jQuery Superfish Menu Plugin

Author: Joel Birch
License: MIT (http://opensource.org/licenses/mit-license.php) & GPL (http://www.gnu.org/licenses/gpl.html)

Homepage: http://cherne.net/brian/resources/iquery.hoverlntent.html

## tinynav v1.2
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Author: viljamis
License: MIT (http: nsource.org/licen mit-license.php)
Homepage: http://tinynav.viljamis.com

## Selecter v3.1.2

Author: Ben Plum
License: MIT (http://opensource.org/licenses/mit-license.php)

Homepage: http://formstone.it/selecter/

## FitVids 1.1

Author: Chris Coyier + Dave Rupert
License: WTFPL (http://sam.zoy.org/wtfol/)

Homepage: http://css-tricks.com http://daverupert.com http://www.alistapart.com/articles/creating-intrinsic-ratios-for-
video/

Font license info
## Zocial
Copyright (C) 2012 by Sam Collins

Author: Sam Collins
License: MIT (http://opensource.org/licenses/mit-license.php)

Homepage: http://zocial.smclins.com/

## Typicons
Copyright (C) 2012 by Stephen Hutchings
Author: Stephen Hutchings

License: SIL (http://scripts.sil.org/OFL)
Homepage: http://typicons.com/

## |conic

Copyright (C) 2012 by P.J. Onori

Author: P.J. Onori
License: SIL (http://scripts.sil.org/OFL)
Homepage: http://somerandomdude.com/work/iconic/

Page 11 of 12


http://opensource.org/licenses/mit-license.php
http://tinynav.viljamis.com
http://opensource.org/licenses/mit-license.php
http://formstone.it/selecter/
http://sam.zoy.org/wtfpl/
http://www.alistapart.com/articles/creating-intrinsic-ratios-for-video/
http://opensource.org/licenses/mit-license.php
http://zocial.smcllns.com/
http://scripts.sil.org/OFL
http://typicons.com/
http://scripts.sil.org/OFL
http://somerandomdude.com/work/iconic/

## Entypo
Copyright (C) 2012 by Daniel Bruce

Author:  Daniel Bruce

License: SIL (hitp://scripts.sil.org/OFL)
Homepage: http://www.entypo.com

Other:

## WordPress specific CSS (formatting, widgets, etc.) & theme architecture loosely based on the Twenty Fifteen
Standard Theme

Author: The WordPress Team
License: GNU General Public License v2 or later (http://www.gnu.org/licenses/gpl-2.0.html)
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